Steam error code 83 when launching Mass Effect

This forum is to be used for all discussions pertaining to any of the titles or expansions within the Mass Effect series.
User avatar
theant4
Posts: 5
Joined: Sun Jul 24, 2011 6:54 pm
Location: a galaxy far far away...
Contact:
Steam error code 83 when launching Mass Effect

Postby theant4 » Tue Jul 10, 2012 2:40 pm

So I just bought the first Mass Effect game from Steam yesterday and both Steam and the game downloaded/installed without any trouble. However, when I went to launch the game this morning, it acted like it was going to start and then I got a little alert that said "Mass Effect failed to start (error code 83)".

I tried again (several more times for that matter) and now it still acts like it's going to start (with the "Preparing to launch..." and the whole bit) but now I'm not even getting the error code message -- nothing is happening at all.

Naturally I began searching online for a solution to the problem. I see that many different people have had this problem with various games, but all the forum threads that I looked at were at least a year old. I tried exiting and restarting Steam, but that didn't work. I tried going to the game properties in Steam and verifying the integrity of the game cache, but that didn't work either.

There were quite a few suggestions regarding firewalls, but I'll admit I didn't really understand any of them. If anyone could explain it to me or come up with any other suggestions to fix this problem, that would be awesome. I'd love to have not wasted $20...