Page 1 of 1

Quest item vanish *possible spoilers*

Posted: Tue Mar 27, 2007 7:12 am
by Longie
Hey guys,

I was doing Lelani's Sorrow and finally reached the Snowbrook Grotto whilst clearing the dungeons around the area.

Once I was nearing where I had to be, I checked my inventory and realised the Statue of Xeria had disappeared.

Does anyone know how I can get this item back? I have tried visiting all previous people in the quest and the item is gone. Do I have to start another game just to retrieve this item (if so, I'll wait until I've finished it first)?



Posted: Tue Mar 27, 2007 7:34 am
by Golgotha
Not sure how to get it back if you don't have it.
But I don't think you can sell or drop the item.

Double check all characters and you chest for the item you might have over looked it.

If now not sure about getting it again, might can go back and talk to the NPC that gave you the statue, she might have another.

Posted: Wed Mar 28, 2007 7:58 am
by Longie
I re-checked all characters and my stash near the teleporters, it's not there. I even went back through the grotto and (I think) all areas I had been, though it is definitely gone.

I did go to the quest giver, then all people whom I had traded with and killed any monsters which helped get that item and that didn't help. I also noticed the ancestor of the Azunites is still there. Maybe it's some weird Vista issue or perhaps I'm doing things wrong.

Another quest also stuffed up, I can't open a chest I need to to complete it. I might try this on an XP machine and see what happens.


Posted: Wed Mar 28, 2007 9:54 am
by QuenGalad
Well, the ancestor of the azunites standing around is not a bug. He will always be there.
As to the statuette, that seems a worse problem. Never happened to me with any of those items. You can't get another from the npc, tha's for sure, because those items always lie around them, and when you are given something, it's not there any more. Seems to me it's rather a strange bug...
What chest are you speaking about?

Posted: Sun Apr 01, 2007 10:18 am
by Longie
I tried doing a multiplayer game and seeing if I could get the statuette again, though it thinks another player is already on the network with any name I put again, haha. I'll wait until I finish it, then go back and do it again.

The chest I'm referring to is the last one in Amren's Vision, after you visit all four mushroom patches. I went through there with my main character and Lothar, Amren was too far away and didn't make it through the teleporter. I tried to open the chest and it said that I needed Amren selected to do that. Now the chest does nothing when I try to open it :/

Posted: Sun Apr 08, 2007 2:17 am
by Gurkha
Sounds Like A PROBLEM

my question is do you really need the statuette??

You may want it to say that uve done all the quests tho!