KotOR for WineX/Linux!

This forum is to be used for all discussions pertaining to BioWare's Star Wars: Knights of the Old Republic.
Boiler98
Posts: 4
Joined: Tue May 11, 2004 7:58 am
KotOR for WineX/Linux!

Postby Boiler98 » Tue May 11, 2004 8:04 am

Hello all!

First time Banshee poster, long time BioWare KotOR Forum poster.

I've been out of the KotOR scene for a while now, but am doing my rounds after getting a wonderful piece of e-mail this morning. So for any Linux folks out there...

TransGaming, the makers of WineX, have just released version 3.3.2 which claims supporting for KotOR! Of course, the fates have conspired to inform of this while at work -- so I have yet to try it out. *fingers crossed*

So if you are a Linux user, sans-Xbox, and always wanted to try KotOR, now you can! Or, if you just want to "stick it to the man" by getting KotOR to run on anything but Windows, you can do that too. :)

News of successful installation to come later tonight.

Linda
Posts: 14
Joined: Sun May 09, 2004 1:53 pm

Postby Linda » Tue May 11, 2004 11:05 am

I'll be watching for your results... I plan on installing Knoppix or Gentoo this summer!

Boiler98
Posts: 4
Joined: Tue May 11, 2004 7:58 am

Postby Boiler98 » Tue May 11, 2004 7:25 pm

WineX 3.3.2, KotOR Install - First Impressions

After getting home this afternoon I fired up the PC and began my tinkering to get SW:KotOR working with the latest release of WineX and Linux. Here are some first impressions.

System Config:
P4 2.8GHz, 1G RAM
PNY GeForce4 Ti 4400, 1920x1200 @ 24bpp
Hercules Fortissimo II
Gentoo Linux 2004.1

Installation:
The install went smoothly. No troubles. Installed the 1.03 patch with no problems (other then trying to find a place to download it).

First Run:
None of the KotOR shortcuts worked properly. They loaded the launcher app up correctly, but nothing worked beyond that. Running 'autoexec.exe' straight off the CD fixed this.

KotOR needs to be configured the first time it is run, so I ran the config and made a few changes based on the WineX release notes. I left everything else very simple -- I'll worry about getting the fancy stuff working later.

A long time ago in a galaxy far, far away...
At least, that is what I *should* have seen! None of the movies are playing correctly -- they are running, but you can't see them. It is easy enough to abort out of them (and then turn them off in the settings), but let's be honest... the FMVs rock. This was a disappointment which I hope to find a solution to.

Once started, the game ran as it should!

I have only run around my cabin on the Endar Spire at this point. Real game play will have to wait for another day.

The Ugly:
As noted in the release notes, KotOR "crashes" when it is closed. This means a few things are not cleaned up -- one being the video resolution. If you run KotOR at the natural resolution of you desktop this might not be a problem; unfortunately, KotOR does not support 1920x1200 so I have to exit X and restart it after exiting KotOR.

Final Notes:
Not a bad start. Given a dual boot system, it is still better to use Windows. Once the movies and exit crashing is fixed, it is ready for prime time!

I am currently working on getting WineX to "manage" KotOR. This would put KotOR in a window instead of running it full screen. My hope is that this will fix the resolution problem I have. Maybe even the movies! ;)

Boiler98
Posts: 4
Joined: Tue May 11, 2004 7:58 am

Postby Boiler98 » Wed May 12, 2004 5:01 pm

Update:
I have KotOR running in windowed mode now, using a combination of KotOR's FullScreen settings and WineX config settings. Movies are working in windowed mode!

For the most part KotOR is near 100%, with only minor issues which come with the territory.

Here are few screen caps:
http://www.rightstep.org/kotor/screencaps/kotor_wine01.png
http://www.rightstep.org/kotor/screencaps/kotor_wine02.png
http://www.rightstep.org/kotor/screencaps/kotor_wine03.png

Not a whole lot of graphical settings are available, the above is running with no fancy goodies set.

User avatar
fable
Posts: 30676
Joined: Wed Mar 14, 2001 12:00 pm

Postby fable » Thu May 13, 2004 4:45 pm

I'm turning this into a sticky thread, given the importance of it. :)
To the Righteous belong the fruits of violent victory. The rest of us will have to settle for warm friends, warm lovers, and a wink from a quietly supportive universe.

Boiler98
Posts: 4
Joined: Tue May 11, 2004 7:58 am

Postby Boiler98 » Wed May 19, 2004 3:19 pm

A small update of info:

I recently removed my WineX directory and began using TransGaming's Point2Play application to help manage my games. Two points of interest, in addition to those mentioned above, using this route:

- The "launcher" screen works fine when started from Point2Play.

- If you notice a double mouse after starting the game, updating KotOR to the 1.03 patch will fix that.

Game on!

P.S.
Thanks for the Sticky. :D

User avatar
Koreforce
Posts: 60
Joined: Mon Oct 11, 2004 8:48 pm

Postby Koreforce » Tue Oct 19, 2004 10:05 pm

I would've helped with this, since I have both Comp and Xbox versions (one for work, of course), and I normally use Linux, since it is infitessimally better than Windows, and I was pretty glad to see Kotor for that as well. Also, about the patches, it is possible to "patch" with Xbox Live.....and that was demonstrated by the Yavin Download that became available a while back.
"An eye for an eye...
The world is blind."

Dormouse
Posts: 1
Joined: Sun Nov 14, 2004 12:12 am

Postby Dormouse » Sun Nov 14, 2004 12:18 am

This thread made me have great expectations, however so far i have failed in getting kotor to run properly.

I have the most recent versions of point2play and cedega installed, and all the system tests pass properly [eg 3d accelleration]. Running a radeon 7200: OpenGL renderer string: Mesa DRI Radeon 20030328 AGP 4x x86 TCL

Even under windows this game works playably.

However, using the same install directory and most recent kotor version and all, hitting Game in the launcher only shows a black screen which never goes anywhere or does anything until i stop running games.

It seems to have an issue here, as reported in the status window:

X Error of failed request: GLXBadRenderRequest
Major opcode of failed request: 142 (GLX)
Minor opcode of failed request: 1 (X_GLXRender)
Serial number of failed request: 392
Current serial number in output stream: 393

And when running manually via cedega it reports at the top:
Mesa implementation error: unexpected texture format in radeonChooseTextureFormat
Please report to the Mesa bug database at http://www.mesa3d.org
wine: texstore.c:2260: _mesa_store_compressed_teximage2d: Assertion `texImage->TexFormat' failed.

Any insight into this would be most appreciated. As it stands kotor is the only thing that keeps me booting into windows.

Darth Trahus
Posts: 47
Joined: Thu Aug 04, 2005 1:47 pm

Postby Darth Trahus » Wed Aug 10, 2005 2:43 pm

What version of Linux do you have because I have Redhat and I can get it to work fine, movies and all without windowing the view?

Jazz.z
Posts: 29
Joined: Sat Sep 01, 2007 7:36 am

Postby Jazz.z » Sat Sep 01, 2007 10:43 am

As this thread has been started, somebody knows about a Linux distro Live CD for games including of course Wine X and some famous game emulators such as Scumm Vm?