Help, can't even get Arcanum to start!

This forum is to be used for all discussions pertaining to Troika Games' Arcanum: Of Steamworks & Magick Obscura.
User avatar
Stubbus
Posts: 3
Joined: Wed Jan 02, 2008 8:22 pm
Contact:
Help, can't even get Arcanum to start!

Postby Stubbus » Wed Jan 02, 2008 8:26 pm

I'm getting very frustrated and would really appreciate any help that anyone out there could give me.

I'm running Windows Vista and I have the latest patch and for some reason it still wasn't working with the cd's. So I went out and got the no-cd patch which I installed and tried using. It's getting me a little farther, I'd say I can sometimes get about 2 seconds in before it just vanishes. It doesn't say error, it doesn't give me any message at all, it just vanishes. I know this is probably a problem that other people have had and I've looked to try and fix it myself. I'm running it in compatibility mode with Windows XP and I'm running as the administrator but nothing is helping.

Is there anything I'm missing here? Do I need to change my screen resolution or something crazy like that? Any help at all would be greatly appreciated. Thanks in advance,

User avatar
GawainBS
Posts: 4452
Joined: Fri Oct 27, 2006 3:43 am
Location: Glabbeek, Belgium.
Contact:

Postby GawainBS » Sat Jan 05, 2008 6:50 am

If your a Vista user, my advice is: Install XP. ;)
Seriously, have you tried running it on an other compability mode than XP?

User avatar
Kain123
Posts: 1
Joined: Wed Sep 23, 2009 1:49 am
Contact:

Postby Kain123 » Wed Sep 23, 2009 1:51 am

I'm an XP user, and I get the game crashing anyways! I used to play it on a worse rig and it played beautifully, but now...well...can't even get it to start!

User avatar
GawainBS
Posts: 4452
Joined: Fri Oct 27, 2006 3:43 am
Location: Glabbeek, Belgium.
Contact:

Postby GawainBS » Wed Sep 23, 2009 2:12 am

Are you running it in Compatibility mode?

User avatar
gradea
Posts: 1
Joined: Mon Oct 05, 2009 8:02 am
Contact:

Postby gradea » Mon Oct 05, 2009 8:06 am

Running the game in Safe Mode doesn't work either, I have the same problem on XP, the game starts, then immediately turns itself off, with out an error message.

Admittedly I did have trouble during the install as well.

User avatar
GawainBS
Posts: 4452
Joined: Fri Oct 27, 2006 3:43 am
Location: Glabbeek, Belgium.
Contact:

Postby GawainBS » Mon Oct 05, 2009 8:46 am

There's a difference between Safe Mode and Compatibility Mode: rightclick on the .exe, select the compatibility tab, and then select Win98.

User avatar
fable
Posts: 30676
Joined: Wed Mar 14, 2001 12:00 pm
Location: The sun, the moon, and the stars.
Contact:

Postby fable » Mon Oct 05, 2009 9:32 am

gradea wrote:Admittedly I did have trouble during the install as well.


I've had the appearance of a game start, followed by a CTD, when--as you note--a game wasn't completely installed. The executable launches, doesn't find the files it needs, and closes down correctly. This doesn't have anything to do with running in Safe Mode, however.
To the Righteous belong the fruits of violent victory. The rest of us will have to settle for warm friends, warm lovers, and a wink from a quietly supportive universe.

User avatar
flix
Posts: 301
Joined: Wed Aug 13, 2008 6:45 pm
Contact:

Postby flix » Mon Oct 05, 2009 5:17 pm

Safe mode has nothing to do with it, as noted. Uninstall, reinstall, apply proper patches. Then see where you are.